UK Stationary Engine Forum
 

Go Back   UK Stationary Engine Forum > Main Engine Section > Engine-Only Stuff > Generators

Reply
 
Thread Tools Display Modes
Old 09-10-17, 09:04 PM   #1
trebor
Forum Light User
 
Join Date: Apr 2015
Location: Banbury
Posts: 7
Default Allam-Villiers Query

I have a Villiers powered Allam Mini-Gen I can't separate the engine from the generator, please could someone tell me how it's done. Thanks.
trebor is offline   Reply With Quote
Old 10-10-17, 12:56 PM   #2
trebor
Forum Light User
 
Join Date: Apr 2015
Location: Banbury
Posts: 7
Default

Now sorted!
trebor is offline   Reply With Quote
Old 10-10-17, 02:29 PM   #3
minorman
Forum Supporter 2012
 
minorman's Avatar
 
Join Date: Jul 2010
Location: From a secret location somewhere in England
Posts: 1,178
Default

Let me know as I have recently got one of these. On mine the magneto appears to be poorly.
__________________
I'm going metric inch by inch !
minorman is offline   Reply With Quote
Old 13-10-17, 08:34 PM   #4
minorman
Forum Supporter 2012
 
minorman's Avatar
 
Join Date: Jul 2010
Location: From a secret location somewhere in England
Posts: 1,178
Default

Quote:
Originally Posted by minorman View Post
Let me know as I have recently got one of these. On mine the magneto appears to be poorly.
Not only the magneto, but it appears either a tappet (cam follower) has broken on the exhaust valve or even worse possibly the cam itself. How do you split the genny off of the engine before I go in ?
__________________
I'm going metric inch by inch !
minorman is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 09:05 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.