UK Stationary Engine Forum
 

Go Back   UK Stationary Engine Forum > Main Engine Section > Engine-Only Stuff > Pumps

Reply
 
Thread Tools Display Modes
Old 08-10-17, 08:50 PM   #1
Urbanunicorn
Forum Light User
 
Join Date: Aug 2017
Location: Cwmbran
Posts: 11
Cool Help needed please

Hi everyone, been restoring my lister domestic water pump and before I go any further, can anyone tell me if there should be a oil seal behind the metal cup, preventing oil seeping along the brass shaft? Can't recall seeing one when I stripped it down.
Urbanunicorn is offline   Reply With Quote
Old 08-10-17, 08:57 PM   #2
Robotstar5
Senior Member
 
Robotstar5's Avatar
 
Join Date: Jun 2017
Location: Birmingham
Posts: 1,318
Default

Exploded drawing of the pump here

...and welcome to the forum.

Stuart.
__________________
If you can't fix it with a hammer, it's an electrical problem.
Robotstar5 is offline   Reply With Quote
Old 08-10-17, 09:53 PM   #3
Urbanunicorn
Forum Light User
 
Join Date: Aug 2017
Location: Cwmbran
Posts: 11
Thumbs up

Thank you Stuart
Urbanunicorn is offline   Reply With Quote
Old 08-10-17, 10:06 PM   #4
Appletop
Senior Member
 
Appletop's Avatar
 
Join Date: Aug 2008
Location: Just outside Diss
Posts: 8,531
Default

Short answer. No.
__________________


Potest non melior Petter. milia passuum melius quam Lister
Appletop is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 12:24 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.